Error on Overview Page
Incident Report for FreeAgent
Resolved
We have now released the fix which means the Overview page should now load without error.
Posted Jun 15, 2020 - 12:47 BST
Identified
We are aware that some customers are having trouble when viewing the Overview page and being presenting with a "Sorry, something's gone wrong" error. The cause has been identified and are in the process of releasing a fix. Thanks for you patience while we rectify this issue.
Posted Jun 15, 2020 - 12:37 BST
This incident affected: FreeAgent Web App.