Freeagent App Availability
Incident Report for FreeAgent
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 13:54 BST
Monitoring
The Freeagent application should now be accessible as normal and we're monitoring this closely. Thank you for your patience and understanding.
Posted Sep 17, 2021 - 11:08 BST
Investigating
We're experiencing issues in our data-centre which is affecting the FreeAgent Application. Our Engineers are aware of these issues and are working on a mitigation as our highest priority. We'll keep this status page updated as the matter develops and really appreciate your patience and understanding at this time.
Posted Sep 17, 2021 - 10:44 BST
This incident affected: FreeAgent Web App and API.