Problems Uploading Files Into FreeAgent
Incident Report for FreeAgent
Resolved
We've identified the cause of the trouble, and have released a fix. Reloading any page where you were experiencing problems should result in you being able to upload files again. Thanks for your patience.
Posted Nov 19, 2019 - 13:47 GMT
Investigating
We are aware that some customers are having trouble uploading files into FreeAgent, preventing the import of bank statements and attachment of files to transactions, expenses and bills. We are investigating this as a high priority and really appreciate your patience and understanding.
Posted Nov 19, 2019 - 13:06 GMT
This incident affected: FreeAgent Web App.