Application performance impaired
Incident Report for FreeAgent
Resolved
Application performance is back to normal.
Posted May 18, 2021 - 13:20 BST
Monitoring
We have pushed a fix and are now monitoring the situation. Application is returning to normal expected speed.
Posted May 18, 2021 - 12:19 BST
Identified
We are currently investigating a slow down in application performance. Our Incident Team have identified the issue and are currently looking to resolve as soon as possible.
Posted May 18, 2021 - 11:51 BST
This incident affected: FreeAgent Web App.