Website Unavailable
Incident Report for FreeAgent
Resolved
Our upstream provider has resolved the issue and our website is back to normal operation.
Posted Mar 09, 2022 - 17:37 GMT
Identified
Our website is currently experiencing connection issues. A fix is being worked on by our provider.

Access to FreeAgent itself should be working as normal. You can access the FreeAgent application via “https://login.freeagent.com/login” which should allow you to log in as normal.
Posted Mar 09, 2022 - 14:18 GMT
This incident affected: Website.