Connectivity Issues
Incident Report for FreeAgent
Resolved
This incident has been resolved.
Posted Jun 12, 2020 - 10:18 BST
Monitoring
Connectivity issues have now been resolved by our network provider.
Posted Jun 12, 2020 - 08:59 BST
Identified
Some users may be experiencing issues connecting to our application and website at the moment. This is due to an upstream network issue which is currently been investigated by our provider.
Posted Jun 12, 2020 - 06:54 BST
This incident affected: Mobile (iOS app, Android app) and FreeAgent Web App, API, Website.