Email Delivery Failures

Incident Report for FreeAgent

Resolved

This incident has been resolved.
Posted Oct 07, 2020 - 17:33 BST

Investigating

We’re currently experiencing issues with one of our email sending platforms. We have switched all services to another platform. Prior to this, some emails will have been delivered to Spam or failed to deliver.

Our engineering team is currently working to resolve the issue.
Posted Oct 07, 2020 - 17:16 BST
This incident affected: FreeAgent Web App, API and Mobile (iOS app, Android app).