Some customers may have issues accessing FreeAgent

Incident Report for FreeAgent

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 15:24 GMT

Investigating

We are currently investigating the issue.
Posted Mar 12, 2026 - 15:01 GMT
This incident affected: FreeAgent Web App.