Email Delivery Failures
Incident Report for FreeAgent
Resolved
A fix has been implemented by the third party email sender. This has been tested and confirmed by our engineering team. Our monitoring shows our multiple delivery platforms are fully working.

All emails that failed to be delivered yesterday during this incident have been re-sent.
Posted Aug 01, 2022 - 12:27 BST
Identified
We’re currently experiencing issues with one of our email sending platforms. We have switched all services to another platform. Prior to this, some emails will have been delivered to Spam or failed to deliver.

Our engineering team is currently working to resolve the issue.
Posted Jul 31, 2022 - 11:34 BST
This incident affected: FreeAgent Web App.