Degraded performance
Incident Report for FreeAgent
Resolved
This incident has been resolved.
Posted Jan 11, 2021 - 09:32 GMT
Identified
We are currently under a persistent DDoS attack on both our application and website resulting in degraded performance.
Posted Jan 08, 2021 - 20:54 GMT
This incident affected: FreeAgent Web App, API, Website and Mobile (iOS app, Android app).