Delays in updating email delivery status

Incident Report for FreeAgent

Resolved

We have identified the root issue and have implemented a fix.
Posted 30 days ago. Feb 12, 2025 - 12:15 GMT

Investigating

We are currently experiencing problems updating the delivery status of emails sent via FreeAgent. We are investigating this issue.
Posted 30 days ago. Feb 12, 2025 - 12:02 GMT
This incident affected: FreeAgent Web App.