Website issues at www.freeagent.com

Incident Report for FreeAgent

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 16:30 GMT

Identified

We are currently experiencing an issue with our website where it is intermittently unavailable. We are working to resolve this as soon as possible.

The FreeAgent application remains unaffected by this, to log into FreeAgent directly please visit https://login.freeagent.com
Posted Feb 18, 2025 - 15:10 GMT
This incident affected: Website.