Delays to some emails sent from within the FreeAgent application
Incident Report for FreeAgent
Resolved
This incident has been resolved.
Posted Feb 14, 2020 - 15:05 GMT
Monitoring
All users are now able to send email from within the FreeAgent application without delay. We identified the issue as being an unusually high volume of emails triggering a rate limit with one of our third party email providers. Our engineering team have updated our email thresholds and proactive monitoring systems to mitigate the risk of future email delays for our users. We will continue to monitor sending to ensure service is not disrupted throughout the day.
Posted Feb 14, 2020 - 11:04 GMT
Update
The emails that were delayed from yesterday evening have all been sent. Some users may see a delay to emails sent this morning. We are continuing to monitor the situation and are aiming to restore full service to everyone as a matter of priority.
Posted Feb 14, 2020 - 10:24 GMT
Investigating
We have become aware of a backlog of emails affecting some FreeAgent accounts that started around 1935 yesterday evening. We are working with one of our third-party email providers to resolve this as a matter of priority. We will send out further updates throughout the day.
Posted Feb 14, 2020 - 09:46 GMT
This incident affected: FreeAgent Web App.