Telephone Support Unavailable
Incident Report for FreeAgent
Resolved
The telephone support number has been restored by our provider. Our phone support is now available if you need to contact us.
Posted Jun 19, 2020 - 14:14 BST
Identified
We have spoken to our upstream provider who is looking at telephone routing issues with Vodafone currently. Application availability remains unaffected.

In the interim, please email support@freeagent.com
Posted Jun 19, 2020 - 13:58 BST
Investigating
We are aware that our telephone support number is not currently available and are investigating with our upstream provider. The FreeAgent application availability remains unaffected.

In the interim, please email support@freeagent.com
Posted Jun 19, 2020 - 13:14 BST