Customers blocked from logging into FreeAgent

Incident Report for FreeAgent

Resolved

This incident has now been resolved and customers should be able to login into their accounts again.
Posted Apr 25, 2025 - 15:33 BST

Investigating

We are currently investigating an issue where some customers are being blocked from logging into their FreeAgent accounts.
Posted Apr 25, 2025 - 14:57 BST
This incident affected: FreeAgent Web App.