Some users are experiencing issues with logging in to FreeAgent

Incident Report for FreeAgent

Resolved

This incident has been resolved.
Posted 2 years ago. Jan 24, 2023 - 10:25 GMT

Investigating

We are currently investigating this issue.
Posted 2 years ago. Jan 24, 2023 - 09:52 GMT
This incident affected: FreeAgent Web App.