FreeAgent Support Unavailable
Incident Report for FreeAgent
Resolved
The issue with our upstream support platform provider has now been resolved, and all support channels are now functioning and available.
Posted Sep 09, 2020 - 16:07 BST
Monitoring
Our support provider is coming back on-stream and we are monitoring services and slowly re-enabling our various support channels.
Posted Sep 09, 2020 - 14:18 BST
Identified
We’re currently experiencing issues with our support platform. While the issue is ongoing you won’t be able to get through to the support team at all.

However, the application remains unaffected.

Our support software provider is currently investigating.
Posted Sep 09, 2020 - 13:08 BST