Our Signup Page Is Currently Unreachable
Incident Report for FreeAgent
Resolved
A fix has now been released and our signup page is back in business. Thank you for your patience and we look forward to seeing you in FreeAgent.
Posted 10 months ago. Nov 21, 2018 - 12:08 GMT
Identified
We have identified the cause of the issue and our Engineers are pulling together a fix. Our signup page should be back up and running shortly. Thanks for your patience and we'll post another update shortly.
Posted 10 months ago. Nov 21, 2018 - 11:40 GMT
Investigating
We're aware that customers trying to sign up for new FreeAgent accounts are currently having issues loading our signup form. Don't worry, we're on the case 🔍 We promise we're worth the wait!
Posted 10 months ago. Nov 21, 2018 - 11:25 GMT
This incident affected: FreeAgent Web App.