Emails to Google Email accounts being marked as spam

Incident Report for FreeAgent

Resolved

This incident is now resolved. Emails sent from the FreeAgent app to Google email accounts should no longer be marked as spam for recipients.

Our vendor, working with Google, deployed a fix at 2025-03-24 23:04 UTC. They continued to monitor email delivery and declared the issue fully resolved at 2025-03-25 02:11 UTC
Posted Mar 25, 2025 - 09:30 GMT

Investigating

We are aware of email deliverability issues to Google email accounts for emails sent from the FreeAgent application.

Emails sent to Google are being incorrectly marked as spam for users. We are currently working on resolving this issue with our email vendor.

In the meantime it is advised that customers check their spam email folder and select the “Report as not spam” option on the email.
Posted Mar 24, 2025 - 16:28 GMT
This incident affected: FreeAgent Web App.