Application performance impaired
Incident Report for FreeAgent
Resolved
The fix has been deployed and application performance is back to normal.
Posted Sep 06, 2023 - 14:57 BST
Identified
We are currently investigating a slow down in application performance. Our Incident Team have identified the issue and are currently looking to resolve as soon as possible.
Posted Sep 06, 2023 - 14:28 BST
This incident affected: FreeAgent Web App, API and Mobile (iOS app, Android app).