Some customers getting redirected to our fraud page

Incident Report for FreeAgent

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 12:25 BST

Monitoring

Our security systems are continuing to protect against the credential stuffing attempt.

We have now made some changes to reduce the risk of legitimate users being redirected to our fraud page.

Again, we would like to assure you that FreeAgent has not been breached and we continue to protect accounts whilst monitoring any further attempts.
Posted Aug 14, 2025 - 16:11 BST

Identified

Our security systems have successfully identified and blocked a number of logins that were part of a large-scale credential stuffing attempt. This is a common tactic where malicious actors use usernames and passwords stolen from other websites and attempt to use them to log in to FreeAgent accounts.

However, this has unfortunately led to a small number of legitimate users being temporarily blocked. We're really sorry if this has impacted you.

If you are redirected to our fraud page, please wait 20 minutes before attempting to log in again. When you do, please double-check that you're entering your username and password correctly.

We would like to assure you that FreeAgent has not been breached and we continue to protect accounts whilst monitoring any further attempts.
Posted Aug 14, 2025 - 11:39 BST

Investigating

We are aware that some genuine customers are being incorrectly redirected to our fraud page and are actively investigating the issue.
We apologise for the inconvenience and will post an update shortly.
Posted Aug 14, 2025 - 09:32 BST
This incident affected: FreeAgent Web App.