Website partially unavailable
Incident Report for FreeAgent
Resolved
A fix has been applied and the website is now working as intended.
Posted Mar 25, 2021 - 16:58 GMT
Identified
Our website is currently experiencing connection issues. As a work around, you can access the website via “www.freeagent.com” which should allow you to connect as normal. A fix is being worked on by our provider.

Access to FreeAgent itself should be working as normal.
Posted Mar 25, 2021 - 15:57 GMT
This incident affected: Website.